R和R包的安装

R的最新版需要专门去CRAN镜像下载安装文件。Ubuntu库里面的R通常不是最新版。如果要重新安装,则最好清空之前安装的软件包。例如删除掉“/usr/local/lib/R/site-library”之类的。然后重新安装R。

完成之后,后来安装的很多包,例如”devtools”, “EpiEstim”可能依赖Ubuntu的编译功能和Ubuntu系统的软件包。因此,最好在Ubuntu安装一下编译包,例如运行一下“sudo apt install build-essential libcurl4-gnutls-dev libxml2-dev libssl-dev”之类的。再继续安装一下lapack之类的软件包。根据R里面安装的提示,还需要去下载相应的包。这个R包管理上和Ubuntu系统包没有整合在一起,比较麻烦。只好不断地发现错误,不断地补充包。

其中有一个软件包源程序(stringi/icudt61l.zip)很难获得,需要单独去下载回来(http://www.ibspan.waw.pl/~gagolews/stringi/icudt61l.zip),然后本地安装。或者到网络好的地方多安装几遍。

本地安装方法,例如:install.packages(“~/dplyr-master.zip”, repos=NULL, type=”source”),或者 install.packages(“~/EpiEstim3_src/EpiEstim”, repos=NULL, type=”source”)

发表评论

电子邮件地址不会被公开。 必填项已用*标注